Installing Page Speed in Firefox 4.0.1

You may be getting an error message when trying to install Page Speed in Firefox 4.0.1.

"Page Speed could not be installed because it is not compatible with Firefox 4.0.1."

They lie. It is compatible. To force it to install on your system you just need to follow these instructions:

  1. Install Firefox 4.0.1
  2. Right Click, Save As https://dl-ssl.google.com/page-speed/current/page-speed.xpi
  3. Use 7-Zip (its free) to Open the Archive.
  4. Right click on install.rdf and select Edit
  5. Change <em:maxVersion>2.0.0.*</em:maxVersion> to <em:maxVersion>5.0.0.*</em:maxVersion> (any higher number should do)
  6. Save then close the file
  7. Confirm that you DO want to update the file in the archive.
  8. Open your modified page-speed.xpi with Firefox and Install.
Comments for this blog entry